Souhaitez-vous participer à la création d'un jeu vidéo inspiré de Stardew Valley, ou le tester lorsque la version bêta sera disponible ? Remplissez notre sondage ou inscrivez-vous à notre lettre d'information (en bas de page)
1

PHPMyAdmin accents

le  2-10-2014 à 15:39 #
Bonjour,

Je suis actuellement en train de m'exercer au PHP avec la connexion à une base de données avec phpMyAdmin (J'utilise WampServer), je suis donc les fabuleux tutoriels d'Openclassrooms. J'ai donc réussi à me connecter à ma BDD, et à y extraire les infos que je voulais.

Le problème, c'est que lors de l'affichage, les accents sont remplacés par des " ? "... l'encodage de Notepad++ est en UTF-8 et l'interclassement de mes tables est en latin_swedish_ci (par défaut)...

Please help ^^
Re: PHPMyAdmin accents
le  2-10-2014 à 15:48 #

le  2-10-2014 à 15:39, @Franklin000 :

l'encodage de Notepad++ est en UTF-8 et l'interclassement de mes tables est en latin_swedish_ci (par défaut)...


Utilise le même encodage pour les deux, soit tu met notepad en latin-1 soit ta base de donnée en UTF-8.
Re: PHPMyAdmin accents
le  2-10-2014 à 15:58 #
J'ai essayé, et ça ne change rien :(
Re: PHPMyAdmin accents
le  2-10-2014 à 16:17 #
Ça peut être complexe, sans connaitre exactement ton code et ce que tu fais, et même les versions des différents éléments de WAMP, c'est difficile à dire d'où vient le problème. Le plus simple à mon avis serait de recommencer à neuf, en faisant attention à ce que tout le monde se parle avec le même encodage (utf8 par exemple).

Tout le monde c'est la base de données (champs texte de la table), la connexion vers la base de données, le script php (via notepad++), la page html.
Re: PHPMyAdmin accents
le  2-10-2014 à 16:55 #
C'est bon ! J'ai rajouté cette ligne juste après la connexion à ma base de données :
mysql_query("SET NAMES UTF8");

En fait, j'avais déjà testé sauf que ça marchait pas pour une raison inconnue, du coup j'ai tout refait d'une autre façon, et maintenant ça marche ^^

Merci Ben :)
Re: PHPMyAdmin accents
le 13-10-2014 à 20:36 #
Salut

j'ai rencontré le même problème, c'étaient même pas des "?" qu'il y avait, mais des entrées vides. C'était très énervant, car cela a beaucoup entravé le développement de mon site.

Alors voilà, ma question c'est, peux-tu expliquer la commande "SET NAMES UTF8" ? NAMES est le nom de la table SQL ?

Merci
M.
Re: PHPMyAdmin accents
le 14-10-2014 à 21:08 #
Non, en fait la commande demande juste à ce que les tables MySQL soient affichées en UTF-8 (Si je dis pas de conneries...)
Des entrées vides, tu dis ? C'est étonnant... Tu pourrais faire un screenshot de ton affichage ?

(Modifié par Franklin000 le 14-10-2014 à 21:08)
Re: PHPMyAdmin accents
le  4-12-2014 à 22:28 #
Re,

je crois que j'ai trouvé le truc, en effet il faudrait que je mette tout en UTF-8 mais j'ai laissé ça de côté j'y reviendrai plus tard

A+




Ces discussions pourraient vous intéresser également:


phpmyadmin
phpmyadmin chez ovh