Souhaitez-vous participer à la création d'un jeu vidéo inspiré de Stardew Valley, ou le tester lorsque la version bêta sera disponible ? Remplissez notre sondage ou inscrivez-vous à notre lettre d'information (en bas de page)
1

date automatique dans une cellule Exel

le 30-09-2016 à 16:46 #
Salut,
Je voudrais que la date automatique dans ma cellule A2 apparaisse uniquement quand je renseigne ma cellule A1
Savez-vous comment faire?
Re: date automatique dans une cellule Exel
le 30-09-2016 à 21:34 #
Salut,
Si tu n'as pas encore trouvé la solution...

Sur Libre office, ça doit etre pareil sur excel.
formule dans la cellule A2 (qu'il faut mettre en format date, sinon on a un nombre)
=SI(ESTVIDE(A1),"",AUJOURDHUI())

en clair,
si la cellule A1 est vide alors la cellule A2 aura comme valeur ce qu'il y a entre les guillemets "", en l'occurence rien.
sinon A2 affiche la date d'aujourd'hui AUJOURDHUI()
la syntaxe:
Si ( élément de comparaison , valeur ou formule si vrai , valeur ou formule si faux )



(Modifié par qn le 30-09-2016 à 21:35)
Re: date automatique dans une cellule Exel
le 30-09-2016 à 22:00 #
Non dsl ça ne fonctionne pas..
Re: date automatique dans une cellule Exel
le  1-10-2016 à 00:26 #
http://www.activassistante.com/vie-pro-perso/bureautique-info/excel/si-est-vide-une-formule-excel-magique/
remplace les virgules par des points virgule...
=SI(ESTVIDE(A1);"";AUJOURDHUI())

bizarre, j'ai mis des points virgule qui sont devenus des virgule dans la barre des formule de libre office.
Re: date automatique dans une cellule Exel
le  1-10-2016 à 08:03 #
Super !!génial merci ça fonctionne trop bon!!!

Ajout du 01-10-2016 à 08:14:

encore une question !et si dans une autre case je souhaite voir un numéro de facture qui est déjà remplie, mais que je souhaite le voir uniquement quand je renseigne une case?
Re: date automatique dans une cellule Exel
le  1-10-2016 à 13:17 #
encore une question !et si dans une autre case je souhaite voir un numéro de facture qui est déjà remplie, mais que je souhaite le voir uniquement quand je renseigne une case?


ce que tu veux faire est objectivement impossible, un truc circulaire.
toute formule mis dans la cellule remplace le contenu de la cellule.

au mieux
soit le numéro dans la formule de la cellule
=SI(ESTVIDE(A1);"";"NUMERO DE FACTURE")

soit le numéro dans une autre cellule en dehors de la zone d'impression
=SI(ESTVIDE(A1);"";"Z1")

si le nom de ton fichier contient le numéro de facture, on peut extraire ce numéro du titre... c'est compliqué
=SI(ESTVIDE(A1);"";formule pour extraire le num du nom du fichier)
ça devrait etre plus facile si le numéro est sur les onglets (feuille1, feuille2...)


Par expérience, il y a un gros probleme pour la date automatique.
Quand tu ouvres le fichier plus tard, bah ça remplace avec la date du jour, du coup tu n'as plus la date d'origine.




Ces discussions pourraient vous intéresser également:


Reconnaitre un format date dans une cellule
insertion automatique de date dans excel
excel date automatique ?
Macro - Insertion d'image dans une cellule
windows se relance à la date d'installation et plus à la date du jour