Souhaitez-vous participer à la création d'un jeu vidéo inspiré de Stardew Valley, ou le tester lorsque la version bêta sera disponible ? Remplissez notre sondage ou inscrivez-vous à notre lettre d'information (en bas de page)
1

Paramètrer OpenDNS sous Windows plutôt que sur le routeur

le 20-12-2016 à 15:49 #
Bonjour tout le monde,
Dans le but de filtrer l'accès à internet de certains périphériques de mon réseau, je souhaite utiliser OpenDNS.
J'ai créer un compte sur le site, y ai renseigné mon adresse publique et configurer 1 site à bloquer pour faire un test.
J'ai un routeur derrière ma box qui gère mon réseau. Lorsque je rentre les IP des 2 DNS dans les paramètres du routeur, pas de problèmes, le filtre d'OpenDNS fonctionnent parfaitement sur tous les périphériques (tablettes, PC, ...).
Mais lorsque je souhaite ne filtrer, par exemple que mon PC (windows), je renseigne les IP des DNS dans la config TCP/IPv4 et je remet le paramètre DNS du routeur en auto; je purge le cache DNS du PC et reboot le routeur. A ce moment là, le filtre ne fonctionne pas. L'ipconfig me confirme bien que les paramètres DNS du PC ont été pris en compte, et sur le routeur le DNS à automatiquement été remplacé par l'IP locale de ma box.
En faisant plusieurs essais, je m’aperçois que, quelles que soient les DNS que je renseigne dans les config du PC et du routeur, c'est toujours les DNS du routeur qui sont pris en compte pour la totalité du réseau.
Il me semblait que c'est le périphérique qui va interroger le DNS et non le routeur ou le modem et que les paramètres DNS du routeur ne sont lues qu'en l'absence de déclaration de DNS du périphérique.
Si oui, pourquoi est-ce que ça ne fonctionne pas ?
Si non, comment ne pas filtrer tous les périphériques ?

(Modifié par Retrax le 20-12-2016 à 15:51)
Re: Paramètrer OpenDNS sous Windows plutôt que sur le routeur
le 20-12-2016 à 17:02 #
Salut,

As-tu redémarré le PC après avoir changé la config ? C'est préférable parce qu'il y a plusieurs niveaux de caches (un flushdns ne suffit pas toujours pour que le navigateur prenne les nouveaux dns en compte)

Normalement ça devrait fonctionner. Un "nslookup domaine.com" à la ligne de commande te donnera plus d'informations.

Ben
Re: Paramètrer OpenDNS sous Windows plutôt que sur le routeur
le 20-12-2016 à 18:24 #
Merci d'avoir pris le temps de répondre.
J'ai bien redémarrer le PC et le routeur après modif et nslookup m'indique bien que le dns est celui que j'ai configuré dans le tcp/ip, mais les requêtes envoyée depuis le navigateur passent par le dns configuré dans le routeur.
Bref je peux rentrer n'importe quel dns dans le pc, c'est toujours le routeur qui a le dernier mot.
Re: Paramètrer OpenDNS sous Windows plutôt que sur le routeur
le 20-12-2016 à 18:31 #
Mmmmh, donc nslookup passe bien par OpenDNS mais pas le navigateur ?

C'est quel navigateur ? A-t-il un proxy de configuré ? Parfois les antivirus installent leur propre proxy, pour éviter justement qu'on te mette un serveur dns frauduleux.
Re: Paramètrer OpenDNS sous Windows plutôt que sur le routeur
le 20-12-2016 à 18:35 #
Même problème avec la tablette android. Ip fixe, déclaration dns, mais c'est le routeur qui a le dernier mot.

Ajout du 20-12-2016 à 19:02:

oups... j'ai même pas répondu aux questions.
Donc oui, nslookup indique bien opendns, mais si je ne rentre pas les dns dans le routeur, les filtres d'opendns ne sont pas appliqués.
Et c'est là qu'est le problème, je veux pas filtrer tous les PC et tablettes.
J'utilise Firefox mais comme je disais, le problème est le même sous android. Et bien sûr je ne passe pas par un proxy.

(Modifié par Retrax le 20-12-2016 à 19:04)

Ajout du 20-12-2016 à 19:13:

Re: Paramètrer OpenDNS sous Windows plutôt que sur le routeur
le 20-12-2016 à 19:17 #
Si ça marche avec nslookup, il n'y a pas de raison que ça ne puisse pas marcher sous Firefox.

Tu as vérifié pour le proxy ? (options -> avancé -> réseau -> connexion -> paramètres)

Quel antivirus utilises-tu ? Quel est ton FAI et le modèle du routeur ?

Ajout du 20-12-2016 à 19:21:

Pense aussi à vider le cache du navigateur quand tu testes les pages pour dire si OpenDNS fonctionne.

Tu peux faire un

nslookup -type=txt debug.opendns.com.

pour avoir plus d'infos.
Re: Paramètrer OpenDNS sous Windows plutôt que sur le routeur
le 20-12-2016 à 20:00 #
Le problème ne doit venir ni du navigateur, ni de l'antivirus, car c'est le même problème avec une tablette androïd.
En ce qui concerne mon routeur, c'est un olitec rw-400n. Mon FAI est ozone.
Re: Paramètrer OpenDNS sous Windows plutôt que sur le routeur
le 20-12-2016 à 20:16 #
Le problème de la tablette peut être distinct.

nslookup se connecte au bon serveur dns, par défaut le navigateur fait exactement la même chose, il faut déterminer ce qui l'en empêche.

-> nslookup -type=txt debug.opendns.com.
Re: Paramètrer OpenDNS sous Windows plutôt que sur le routeur
le 20-12-2016 à 20:23 #
J'avais fait un nslookup vers une autre adresse, car le domaine spécifié debug.opendns.com semble ne pas exister.
Re: Paramètrer OpenDNS sous Windows plutôt que sur le routeur
le 20-12-2016 à 20:27 #
Quel antivirus tu as ? Pour Avast il faut désactiver Secure DNS.

(Modifié par ben le 20-12-2016 à 20:29)
Re: Paramètrer OpenDNS sous Windows plutôt que sur le routeur
le 20-12-2016 à 20:38 #
J'ai effectivement avast, mais la version gratuite. Secure DNS n'est dispo que dans les versions Pro, Premium ou Internet Security.
Dans le doute, je viens quand même de faire un essai en désactivant complètement avast et après avoir purgé le cache du navigateur, le problème reste le même.
Re: Paramètrer OpenDNS sous Windows plutôt que sur le routeur
le 20-12-2016 à 21:05 #
Le fait que tu ne puisses pas questionner debug.opendns.com. suggère qu'en fait ça ne marche pas non plus via nslookup, ça semble fonctionner mais en réalité les réponses ne proviennent pas d'OpenDNS.

Tu as raison, c'est du coté du routeur, il y a quelque chose de très inhabituel. Peut-être dans les fonctions avancées ? Domain Filtering ? Blocage ou redirection du port 53 ?

As tu essayé de laisser les dns vides dans le routeur ?

Sinon peut-être mettre opendns en dns secondaire dans le routeur (celui du FAI comme primaire), puis sur le PC mettre OpenDNS en primaire et secondaire (et sur les autres appareils celui du FAI), c'est tordu mais il se pourrait que sa marche.
Re: Paramètrer OpenDNS sous Windows plutôt que sur le routeur
le 20-12-2016 à 22:13 #
Si on commence à taper dans les fonctions "avancées" de ce routeur, ça va aller vite, il n'y en a pas beaucoup. Pas de domain filtering. Possibilité de filtrer les clients par IP, ou par adresse MAC et de filtrer des URL, mais aucun des 3 n'est actif. Au niveau des ports, aucun déclenchement de configuré et aucune restriction ou redirection sur le port 53.
Si je laisse le paramétrage DNS en manuel avec les champs vides, j'ai un message d'erreur (DNS non valide). Idem si je met 0.0.0.0
J'ai eu un peu de mal à trouver le DNS de mon FAI. Je pense que c'est 82.98.11.26. Je l'ai donc mis en primaire et celui d'OpenDNS 208.67.222.222 en secondaire. J'ai purgé le cache fiferfox, rebooté PC et routeur : pas de changement.
J'ai remis le DNS de OpenDNS dans le retour, ça fonctionne, mais comme avant, ça filtre tous mes périphériques (ça on le savait déjà), et j'ai refait un nslookup pour voir ce que ça donne :


Ajout du 20-12-2016 à 22:17:

Donc oui, c'est bien le routeur qui change le DNS de la requête du navigateur.
Les tests que tu m'as fait faire semblent le confirmer.
Dès que je peux j'essaye de me brancher en direct sur la box ou d'essayer avec un autre routeur.
Re: Paramètrer OpenDNS sous Windows plutôt que sur le routeur
le 22-12-2016 à 20:32 #
J'ai donc essayé en me branchant directement sur la box. En renseignant les DNS d'OpenDNS des les paramètres TCP/IP de la connexion du PC, ça fonctionne. Même chose sur une tablette.
J'ai changé mon routeur Olitec, par un TP-Link, dans lequel il est possible de ne rien mettre dans les champs DNS. Connexion sans DNS : OK. Avec DNS juste sur le PC : OK, le filtrage fonctionne et uniquement sur le PC.
Donc c'était bien mon routeur qui changeait le DNS dans les requêtes du navigateur.
Merci pour ton aide BEN.
Bonne fêtes de fin d'année.
Re: Paramètrer OpenDNS sous Windows plutôt que sur le routeur
le 22-12-2016 à 21:12 #
Comme quoi certains routeurs redirigent le port 53 sans rien dire, je ne leur ferai plus confiance!

Joyeuses fêtes à toi aussi!




Ces discussions pourraient vous intéresser également:


routeur sans fil/USB sous windows 98 seconde edition et windows xp
configurer un routeur ZyXEL sous windows vista
OpenDNS yen a marre
Problème connexion routeur wifi sous vista
LowID émule sous Vista , prob config de routeur netgear !!